packages/packages/beekeeper-studio-bin/PKGBUILD

30 lines
1.3 KiB
Bash

# Maintainer: MedzikUser <nivua1fn@duck.com>
_name='Beekeeper Studio'
_pkgname='beekeeper-studio'
pkgname="${_pkgname}-bin"
pkgver="3.9.20"
pkgrel=1
pkgdesc='Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more'
arch=('x86_64' 'aarch64')
url='https://www.beekeeperstudio.io'
_url_source='https://github.com/beekeeper-studio/beekeeper-studio'
license=('MIT')
depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'nodejs' 'nss' 'xdg-utils')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}-${pkgver}-license::${_url_source}/raw/v${pkgver}/LICENSE.md"
"${_url_source}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
sha256sums=('1409fbbc5265c85da91684660c87f85d74c3fdc63a2d355169f40dac5cc7a078'
'19c7b0a9d9d4c03ae7df7e68e31d03af685f1230be7507638b36aa0968996654')
package() {
tar -xvf 'data.tar.xz' -C "${pkgdir}"
rm -rf "${pkgdir}/usr/share/doc"
install -dv "${pkgdir}/usr/bin"
ln -sfv "/opt/${_name}/${_pkgname}" -t "${pkgdir}/usr/bin"
install -Dvm 644 "${pkgdir}/opt/${_name}/"{'LICENSE.electron.txt','LICENSES.chromium.html'} -t "${pkgdir}/usr/share/licenses/${_pkgname}"
install -Dvm 644 "${_pkgname}-${pkgver}-license" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}